- your source for Metal tabs
Home Forum FAQ Contact Us Link to Us

Go Back Forum > Musicians > Gear & Recording

Old 2009-05-08, 03:04
Arsis's Avatar
Supreme Metalhead
Join Date: May 2007
Location: us
Posts: 577
My british FUCKING AMP...defective?

A week ago I just bought a Marshall DSL 50. I take to a friends house jam out for a while with him on drums. I mvoe it to a different location. Plug it in. Weird burnt ass smell is coming from were the power tubes are plugged in. The volume has decreased also. anyone know what is going on?
Old 2009-05-08, 15:57
Senior Metalhead
Join Date: Sep 2004
Location: Wisconsin
Posts: 368
Where did you get it from?

Did you check to see if any of the power tubes got cracked or were cracked before you jammed?

Did you plug it into the wrong impedence for an extended period of time?

Did you try playing some cradle of filth or slipknot or something ive heard that makes tube amps cringe and commit hara kari
- you suck and your stupid
- Rise of Elitism: Yes the bands you like are gay
Originally Posted by xdislexicx
it was too hifi for me...
it's like a hot chick that is horrible in bed.
Old 2009-05-08, 16:22
The Doctor's Avatar
The Doctor
Forum Leader
Join Date: Jul 2002
Location: Bladel, Holland
Posts: 6,806
Old 2009-05-08, 20:45
Dyldo's Avatar
Throbbing Member
Forum Leader
Join Date: Jul 2002
Location: Californeeway
Posts: 7,909
Sounds like you burnt out a tube. No big deal, just look and see which tube looks burnt (black shit everywhere) and replace it. If you need help finding it (sometimes it isn't that obvious) just take it into a shop. You should also check the fuse.
Check my band out:
i'm so bonery
Old 2009-05-08, 21:31
Arsis's Avatar
Supreme Metalhead
Join Date: May 2007
Location: us
Posts: 577
Bought it from a guitarist in a band that plays with mine some.
Power tubes look fine they both still glow.
Using 4 ohm cab adn 4 ohm head.
No black was identified on the tube.
Fuses looked good.
It smells like burnt capacitor/transformer/resister/any form of circuit board jargon stuff.

In the picture I circled were the smell is strongest from,
Its very tiny bit basically its that little hole thing under the power amp tubes. There are male pins showing.
Old 2009-05-09, 00:31
Mordor's Avatar
Join Date: Apr 2003
Location: Mordor/England
Posts: 1,363
to my understanding the little holes i think that your talking about are the bias points and i've never heard of those cooking, you use them to bias the power tubes for your amp. Anyways, open up your amp and have a quick check of the insides (BUT MAKE SURE THAT YOU DON'T TOUCH THE ELECTRONIC GUTS UNLESS YOU HAVE DRAINED THE CAPACITORS INSIDE) see if anything has fucked up, its most likely going to be a crapped out tube, if not ask around on and show them a hq pic or go to a tech
"many a time newcastle brown hath cometh to my rescue" blizzard beast

Sold my shit, now its time to PARTY!!!!!

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Contact Us | Privacy Policy | Disclaimer
Copyright © 2001-2014 All Rights Reserved.
Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.